We’ll post updates here as soon as we’re aware of any issues. Our systems are automatically monitored, and if something goes wrong, alerts are escalated immediately (including alarms that break through silence modes on our phones). You can subscribe to get emails whenever we post an update.
Resolved
All pending items have now finished processing.
Monitoring
The problem has been fixed and pending items (such as meetings, attachments, and clarity plus) will finish processing over the next few minutes.
Identified
We are aware of some items taking longer to process than usual. We have identified the problem and working on a fix.